Meeting Minutes: Oct 26, 2014

Attendees

Mentors:

  • m_conley (Mike Conley)
  • ChipX86 (Christian Hammond)
  • heapify (Anselina Chia)
  • purple_cow (David Trowbridge)

Students:

  • brennie (Barret Rennie)
  • andrewhong (Andrew Hong)
  • dkus_ (David Kus)
  • nicole_xin- (Nicole Xin)
  • rdone (Ryan Done)
  • mloyzer (Mark Loyzer)
  • justy777 (Justin Maillet)
  • asalahli (Azad Salahli)

Announcements

m_conley (Mike Conley)
We’re pretty much at the half-point. Midterm evaluations got sent off last Friday, so you should be receiving some feedback sometime very soon. If you don’t get feedback from your faculty within the next week or so, make sure to let us know.

Round Robin

andrewhong (Andrew Hong)

  • Spent some time looking into this and I’m not sure if this is a bug, but when switching storage options in the admin panel, should I be needing to restart the server for the changes to apply? For example, when switching the local -> amazon s3, it would still upload files to the local file system. I had to restart the server for it to change over worth filing a bug report.
    • (purple_cow) At the very least we should warn people that they need to restart their web server.
    • (m_conley) hat might be a fine stopgap until we get to the bottom of this. It might be worth doing a preliminary investigation to see how tough of a problem that is to solve. If it’s non-trivial, to put such a warning in the UI while we sort it out.
  • Started digging around rbtools and haven’t jumped back into the autocomplete yet. I’ll get back to the autocomplete first since it seems more important.

asalahli (Azad Salahli)

  • Going to post a WIP, but it didn’t go as expected. There is more work that needs to be done than I expected. The WIP has been posted, but it is nowhere close to what I wanted to get done. Working: Taking the review request, check if its approved, create a new empty commit on top of current branch (with message “reviewed at:…”) and push it to remote. This bit works. Having trouble calling rbt patch form rbt land, if the review request has to be applied first to local repo
    • (m_conley) I believe RBTools commands were designed to be composable, I seem to recall it being possible to call the main function of each command without assuming that main was being called from the rbt harness, and not some other command.
  • Can you point to an example code where main is being called from somewhere else, or any hint to how I can do it?
  • How to determine if I’ve already created an empty commit with just the message. I wanna look at the message of the last commit. There already is SCMTool.get_raw_commit_message(), but I need to pass 2 commit id’s to it, so that I can return everything inbetween, but SCMTool.parse_revision_spec() only returns the last commit id.
    • (purple_cow) Perhaps before we get too depp into the code, we should have a good plan for all of the different cases.
    • (heapify) I’m not sure if creating an empty commit with a message is the best way for rbt land to work.
    • (m_conley) Are you able to hand around after the meeting to see if we can flesh this out more?

brennie (Barret Rennie)

  • I’m wondering if I understand how the HTTP caching is supposed to work. So I made a flow chart that describes how I think its supposed to work (https://www.dropbox.com/s/s46rdynb33nbc9k/flowchart%20for%20caching.png?dl=0
    • (m_conley) This seems to match my understanding
  • I have a WIP that implements most of this behaviour. It just needs to be refactored to support testing. Allow it to specify the URL opener to use so that a fake opener can be used for testing.

dkus_ (David Kus)

  • How do you properly create a review request for a branch that is based off another branch
    • (purple_cow) If your branch structure is master >> backend >> frontend, you can do rbt post frontend for just the last commit on frontent, or rbt post backend..frontend
  • Code style problems. How to properly format https://reviews.reviewboard.org/r/6454/diff/7/?file=59973# (lines 77-82)?
    • (purple_cow) One thing to try: add a newline after the first (, and indent everything only four spaces.

justy777 (Justin Maillet)

  • I have a request from RequestFactory class and I need to insert something in it to get out with request.GET.get(). How do I do that?
    • (m_conley) Doesn’t kgb offer capabilities for preloading method calls with things like this
    • (justy777) Yes, but it caused over 100 tests to fail when I tried that approach.
    • (m_conley) Which tests are you attempting to do this RequestFactory insertion thing for?
    • (justy777) Testing search_users() for reviewboard.accounts.AuthBackend subclasses.
    • (m_conley) Can you stick around after the meeting to help you sort that out?
  • How would someone fix, a function like get_sort_field(self, ….) in Column class being called by StatefulColumn via __getattr__ since it gives an error that for self it returned an instance of StatefulColumn instead of A Column subclass instance?
    • (m_conley) These sort of technical questions are exactly why we like you to ask them in your status reports :). Because right off the top of our heads, I think we don’t know. Stick around after the meeting and we’ll try to sort that out, ok?
  • How well does git/reviewboard put together commits/patches on the same file as long as you’re just adding things? I want to have multiple review requests for the same file, and I want to know if they will interfere with each other.
    • (m_conley) Let’s address this after the meeting.

mloyzer (Mark Loyzer)

  • Nothing blocking from moving forward with the PDF stuff. The documentation on reportlab isn’t the best but I’m making progress, and I’ll be able to do alot more progress this week because 4 midterms done this week.

rdone (Ryan Done)

  • Anything blocking on the slider work? There was some initial ideas I wanted to confirm. It appears that some of this is partially implemented in different places. There’s a FileAttachmentHistory class, the REST API allows for ‘puts’ on an attachment etc. But there are gaps that need filling in. For example, the update button still calls POST to the web server, so an error is returned. (400 Bad Request)
    • (purple_cow) It should be a POST, it’s a new file attachment that’s associated with the same history object. It worked when I pushed all those changes but maybe something regressed
    • (ChipX86) If you check the network tab in the browser’s devtools, you should get more info about what is missing.
    • (m_conley) The server console might also hold some clues
    • (purple_cow) It looks like the javascript is using the name “attachment_history_id” but we renamed that parameter to “attachment_history”
  • Most of this stuff is in place, we just need the gui slider to retreive back the file history
    • (purple_cow / m_conley) Yes.

nicole_x- (Nicole Xin)

Advertisements

Leave a Reply

Fill in your details below or click an icon to log in:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out / Change )

Twitter picture

You are commenting using your Twitter account. Log Out / Change )

Facebook photo

You are commenting using your Facebook account. Log Out / Change )

Google+ photo

You are commenting using your Google+ account. Log Out / Change )

Connecting to %s